Ubuntu安装vim出错,不存在依赖关系

19. December 2015 Linux 0

vim : 依赖: vim-common (= 2:7.3.429-2ubuntu2.1) 但是 2:7.3.547-4ubuntu1 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

原因可能是安装vim所依赖的vim-common和系统自带的vim-common版本冲突,解决办法就是先把vim-common卸载了人然后再安装vim即可.

sudo apt-get remove vim-common

sudo apt-get install vim


Leave a Reply

Your email address will not be published. Required fields are marked *